SVYHLEDAT


Tato funkce zjednodušeně slouží k natažení hodnot z jedné tabulky do druhé na základě shody hledané hodnoty. Pokud je hledaná hodnota z první tabulky vyhledána v prvním sloupci prohledávané tabulky, tak nám funkce vrátí hodnotu z jiného sloupce odpovídajícího řádku prohledávané tabulky. Jedná se o velmi užitečnou funkci, která do jisté míry nahrazuje absenci jednoduché možnosti vytvářet relace mezi tabulkami.

U velkého množství instancí této funkce a zároveň velkého množství prohledávaných buňek je lepší sáhnout po alternativním řešení s využitím Power Pivot datového modelu, kde je možné vytvářet relace mezi tabulkami.
Funkce SVYHLEDAT.

Syntaxe funkce

CZ verze:=SVYHLEDAT(hledat;tabulka;sloupec;[typ])
EN verze:=VLOOKUP(lookup_value,table_array,col_index_num,[range_lookup])

Argumenty funkce

  • Hledat: Povinný argument. Hodnota, která se bude hledat v prvním sloupci prohledávané tabulky. Pro tuto hodnotu bude z prohledávané tabulky vrácen výsledek ze sloupce, ze kterého jej potřebujeme. Například pro kód produktu, který je v prvním sloupci prohledávané tabulky, potřebujeme vrátit jeho cenu, která je ve třetím sloupci prohledávané tabulky. Argumentem hledat může být hodnota nebo odkaz.
  • Tabulka: Povinný argument. Oblast buněk, která bude prohledávána. Můžeme použít odkaz na oblast (například A1:D10000) nebo název oblasti. Pamatujme na to, že se hledaná hodnota bude vyhledávat pouze v prvním sloupci prohledávané tabulky.
  • Sloupec: Povinný argument. Jedná se o číslo sloupce v prohledávané oblasti, kterou jsme definovali argumentem Tabulka. Pokud do tohoto argumentu vložíme číslo 2,tak nám bude funkce vracet hodnotu z druhého sloupce prohledávané oblasti atd.
  • Typ: Nepovinný argument. Jedná se o logickou hodnotu, případně číslo 0 nebo 1, které určují, zda má funkce hledat přesnou nebo přibližnou shodu.
    • Pravda = 1
      Hodnota výsledku bude vrácena pro přesnou nebo přibližnou shodu. Hodnota pro přibližnou shodu bude vrácena v případě, kdy nebude vyhledána přesná shoda, vrácena je automaticky nejbližší nižší hodnota. Pravda se automaticky bere i v případě nevyplnění argumentu Typ. Jedná se o intervalové vyhledávání, hodnoty tak musí být seřazeny vzestupně.
    • Nepravda = 0
      Hodnota výsledku bude vrácena pro přesnou shodu, jinak bude vrácena chyba (#NENÍ_K_DISPOZICI, #N/A). Prohledávaná data nemusí být v tomto případě seřazena, nejedná se o intervalové vyhledávání.
Funkce nerozlišuje malá a velká písmena.

Tento web používá k poskytování služeb, personalizaci reklam a analýze návštěvnosti soubory . Používáním tohoto webu s tím souhlasíte. Další informace